Portál technické podpory

Pokud zde nenajdete to, co jste hledali, neváhejte nás kontaktovat.
Potřebné informace pro vás rádi doplníme.

Změna verze PHP

V rámci linuxových variant webhostingu máte nově možnost měnit verzi PHP přímo z vašeho Centra administrace. Verzování je však povoleno pouze u webhostingových variant, jenž se nachází na novějších serverech. V případě starších serverů, které přepínání nepodporují, je třeba přesun vykonat z naší strany na základě autorizované žádosti.

Kde možnost přepínání verzí PHP naleznete?

Po přihlášení do zákaznického účtu zvolte v levém menu položku [Seznam s hledáním] a rozklikněte detail konkrétní domény. V tomto novém rozhraní pro správu domén vyhledejte po pravé straně možnost [Verze PHP], dále kliknutím na [Změnit] vyberte v seznamu požadovanou verzi a změny potvrďte (možno měnit i samostatně pro jednotlivé subdomény).

Pokud server přepínání nepodporuje, zobrazí se vám následující upozornění:


Podpora PHP verzí


Pokud vaše webové prezentace pracuje na verzích PHP 5.6 a nižší, důrazně doporučujeme kontaktovat tvůrce webu, aby provedl jeho upgrade, neboť pro starší verze PHP již nejsou vydávány žádné bezpečnostní aktualizace ani jiné updaty.

Kompletní přehled o aktuálně (ne)podporovaných verzích je k dispozici zde: http://php.net/supported-versions.php

Upozornění

Abyste se vyhnuli riziku nekompatibility stránek s novou verzí PHP , doporučujeme provést nejprve jeho otestování. V opačném případě nemůžeme zaručit bezproblémovou funkčnost webových stránek, postavených na starších verzích PHP, které by byly přeneseny na server podporující PHP 5.6 a vyšší.

Odladění webové prezentace

U webové prezentace, která je postavena na starší verzi PHP, doporučujeme nejprve otestovat funkčnost a provést její případné odladění. Jednou z možností je přesun webu na testovací subdoménu, další pak vytvoření dočasného aliasu, přes který bude možné web zobrazit, bez nutnosti úpravy souboru hosts.

V případě zájmu nás neváhejte kontaktovat pomocí autorizovaného požadavku.